Root, Custom roms, Utveckling

HTC One installera custom ROM

2015-01-05 14:48 #0 av: Jonsson9

Hej alla! :)

Jag försöker roota och installera en ny custom ROM på min HTC one (M7).

Tyvärr går det inget vidare. När jag rebootar efter att ha installerat ROMen så kommer den först ingenstanns sen startar den om och jag kommer till recoveryn igen.

Har någon något tips på vad jag kan testa för att få det att fungera? Blir så less på det här...

Anmäl
2015-01-05 14:55 #1 av: kissidor

du har alltså inte haft denna rootad eller flashat in rommar i den tidigare? har du provat att flasha om den? har du provat att flasha in nåt annat? testade du hur den var med bara root först eller gjorde du allt i ett svep?

Medarbetare på Mobiltelefoner och Android

Anmäl
2015-01-05 15:06 #2 av: Jonsson9

Nej, ingen root sen tidigare.

Jag har provat att flasha om samma ROM flera gånger, blir precis likadant.

Jag hade i gång den med enbart root. Sen ladda jag ner en ROM och testade. Och nu är jag fast...

Ska se om jag hittar nån annan ROM att testa med.

Men har jag förstått det rätt att det kvittar vilken recovery jag använder? Och kernel flashas tillsammans med ROMen?

Var ett tag sen jag höll på att pilla med sånt här nu.

Anmäl
2015-01-05 15:15 #3 av: kissidor

jo men samma här, i m8:an har jag inte känt suget att ändra nåt - och alla märken måste ju hanteras olika och det är ju gnexen samt en radda samsungar jag fipplat med tidigare, så jag vet inte hur det är med din m7. vissa grundläggande regler som full wipe är förstås allmängiltiga, men jag vet att i både s4 och tror jag note 2 och s3 4g så funkade det inte bra med cwm, jag fick lov att gå över till twrp.

det kan väl knappast vara bra att redan från början flasha kernel separat, vill man prompt byta kernel så gör man väl det efteråt och kollar så att man vet att den är kompatibel. fick du flasha gapps separat eller var den inbakad?

Medarbetare på Mobiltelefoner och Android

Anmäl
2015-01-05 15:51 #4 av: Jonsson9

Okej.

Jag har kört med medföljande kernel. Och recoveryn är twrp, allt enligt guiden till den romen. Det är Aroma installation och där verkar gappsen vara med.

Får ett litet felmeddelande när installationen är klar "set_metadata_recursive: some changes failed"

Anmäl
2015-01-05 16:48 #5 av: Jonsson9

Jag googlade felmeddelandet och kom fram till att det berodde på en för gammal version av TWRP. Jag laddade ner en nyare version och nu fungerar allt som det ska! :) Tack för hjälpen

Anmäl
2015-01-05 17:11 #6 av: kissidor

Det var så lite, jag hjälpte ju inte till egentligen :) - men ibland kan man behöva bolla lite bara medans man tänker själv. Härligt att det funkar nu i alla fall :)!

Medarbetare på Mobiltelefoner och Android

Anmäl